LINUX 下无线网卡 rtl8821CE/rtl8723de 驱动 无法驱动解决办法

首先给大家推荐一下我老师大神的人工智能教学网站。教学不仅零基础,通俗易懂,而且非常风趣幽默,还时不时有内涵黄段子!点这里可以跳转到网站

1. 确保linux内核版本大于 4.14

  1. 如何查看linux 内核版本 :终端 uname -sr
  2. 如果内核版本低于 4.14:升级linux内核 ubuntu可以参照 https://www.linuxidc.com/Linux/2017-03/141940.htm
  3. 升级完记得重启

2. 下载linux中8821CE/rtl8723de的驱动源码

其实linux是支持这款网卡的,但是不知道为什么没有驱动,在源码中都有,貌似ubuntu 18 已经没有这个问题
git原地址(rtl8821CE):https://github.com/endlessm/linux/tree/master/drivers/net/wireless/rtl8821ce
git原地址(rtl8723de):https://github.com/endlessm/linux/tree/master/drivers/net/wireless/rtl8723de
或者本地下载 https://free-1253146430.cos.ap-shanghai.myqcloud.com/rtl8821ce.zip
(/////rtl8723de 的话 自己 去git上下吧)

3.编译驱动

  1. 解压rtl8821ce.zip
  2. 修改文件Makefile
export TopDIR ?= $(srctree)/drivers/net/wireless/rtl8821ce

从这行 “export TopDIR ?= 后面改成当前目录 例如我的:

export TopDIR ?= /home/horsun/Downloads/rtl8821ce
保存修改
  1. 分别进行:
    make
    sudo make install
    sudo modprobe -a 8821ce

然后驱动就装好了

点这里可以跳转到人工智能网站

发表评论